Time out when counting products


It started some days ago:

https://****:@api.ordoro.com/product/counts/**resulted in a504 Gateway Time-out` response:**

I am running it at 1 AM EST and getting this error basically every day in the last 8 days.



Thank you for the heads up, we will be looking into this issue.

Hey Sofia!

Today I got this one:

Client error: `GET **:***@api.ordoro.com/product/?status=active&sort=sku&limit=100&` resulted in a `400 BAD REQUEST` response:

{"error_message": "The input field 'status' was not expected.", "param": null}

I’ve been running both the above and the api.ordoro.com/product/counts for months. THere were no changes at our side.

Thanks and have a great day!

Hi, was this at 1am as well? We saw this error corresponding with a release we made in the afternoon, but it should have cleared up quickly.

That one happened when we tried to re import the data today around 8 AM.

Hmm, What time zone are you in? We don’t have any notices of this error post 6pm CST 09/24.

If this is still an issue, please provide the request ids returned in the header so we can look into this further.

Sorry. Timezone is EST

I tried now and got the first error:
…api.ordoro.com/product/counts/resulted in a504 Gateway Time-out` response:

Hey Sofia.

I’ve just tried both APIs again:

...@api.ordoro.com/product/counts/ worked 3 out of 3 tries, what is good.




    "error_message": "The input field 'status' was not expected.",
    "param": null

I tried
....api.ordoro.com/product/?active=1 with no success.


Hey Sofia, any news?

I’ve just tried api.ordoro.com/product/counts/and it timed out again:
504 Gateway Time-out

is still saying:

    "error_message": "The input field 'status' was not expected.",
    "param": null

Actually, you are making the wrong request for the product endpoint. it should be active=true.


Hope that helps,


I believe this is the post that outlines the changes: Breaking changes to product endpoint

Hey Sofia, thanks for clarifying the status/active change. It works.

@api.ordoro.com/product/counts/ looks to be working now. I will keep an eye on it and let you know if we have any issue.